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How to import database to ASManager!!!

1. How to transfer format from xls to mdb :

Step1-1. Open up Microsoft Access.

Start -> Programs -> Microsoft Access

Activabs Windows
@! Set Program fAccess and Defaults

@ Windows Catalog

‘windows Update

@ Mew Office Document

Open Office Document

Lb Documents
@-' Settings
I:) Search

0/] Help and Support

“=7 Run...

Access Control

) Microsoft Office Tools
[ Resltek Sound Manager
Startup

) UkraEdit

@ Outlook Express
.. Remote Assistance
&) Windows Media Player

] roqoif adminsirator...

(B8] 7o off computer...

Windows XP Profess

4 start =& ¢ [ remp

i Windows Messenger
G Windows Movie Maker

Step1-2. Create a new mdb file(t 3B &rK Microsoft Access FEARERFHA, LI FEL Microsoft Acce2000 £54)
Select “Black Access database” -> OK -> Save(select save path) -> File Name -> Create

ﬁ A;\icrus_nfl Access

| Bie Edic tiew Insert Tooks ‘Window Help

|- = ]x]

PEE SRy 2R v |- 0o fga 3.

" Create a new datahase using
& Blank Access database

base wizards, pages, and projects
e New Database
Savein: [ Deskrop e o @& % BB Toos -
(’ )My Documents isting File
o 4 My Computer
Wk Paces —
pic [ =n =
: s base =l
2 5 ase
8123 - ]
B db1
2 dbz_en
= x|
s
*

File name: [

—

Rl uggeate I

Save a3 bypel [Microsoft Access Databases ] Cancel

[Ready

=& @ [ Temp

1
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2. How to import database(mdb) to ASManager :

Step2-1. Import Excel Data to Access

Select “File” -> Get External Data -> Import

K Microsoft Access

Insert Tools Windaw Help

i @ | o (B (B E 2 3.

CirH0

6 nyk : Database

ficoen BEDosin o | 7 | %

= Ctrl+5
Save A
Export. Objacts Create table in Design view
. Create table by using wizard

Plage Setp .,
[ Print Preview
& print.., ChrlR

Send Ta v
Database Properties

1k

2 Cifceess Controlidb2_en
3 Northwind Sample Database
4 Conkacts Sample Database Groups

Exit

o & ¢ | & Temp 15 ase 4 D0z - Pairk

Step2-2. Import Excel Data to Access

Select “Files of type” -> Microsoft Excel -> Select Excel file (Customer’s database) -> Import

Ed | Microsoft Access ‘:l EHZ'

| Bie Edit view Insert Tools ‘Window Help

IDNedaEshy|laesd|o|%h- B ss a3,

EE nyk : Database

lookin: (@ Desktop o] e @K 5B Toos -

|3 My Documents

J vy Computer
Sy etwork Places
pic

=

File pame: | E.‘* Tt |

Files of type: - [Microsoft Excel Cancel

Microsoft Access
IBASE 5

dBASE 11

=& ¢ | @ Temp
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Step2-3. Import Excel Data to Access

With the default option “Show Worksheets” selected, press “Next” button

& Import Spreadsheet Wizard Ead

Y¥our spreadsheet file contains more than one workshest or range. Which warksheet or range
would you like?

& Show Worksheets
" Show MNamed Ranges

Sample data for worksheet 'myk!.

| 1 Purber First Neme [ast Nawe Access Level e
| 2 [498 Do [Tood GRAND HMASTER

|3 p326 FICEY MARTINEZ [DISTRIEUTICN OFFICE

| 4 330 MELINDAL FATELE DISTRIBUTICH OFFICE

|5 B33l LIZ HERNANDEZ DISTRIEUTICN OFFICE

| 6 p332 [F.LTUL FANIREZ FUMA Whs (AHM) v}
. 2

Cancel ] = Back ] [ext = | Einish ]

Step2-4. Import Excel Data to Access

Press “Next (*Please make sure “First Row Contains Column Headings” is checked)” button

& Import Spreadsheet Wizard _

Microsoft Access can use your column headings as field names for vour table. Does the First
row specified contain calumn headings?

(V First Row Contains Column Headings ]

MNurder |[First Name |Last Name Access Lewvel
| 1498 [Doug [Tood GRAND HMASTER -
|2 p328 FICEY MARTINEZ [DISTRIBUTICON OFFICE
|3 p330 MELINDL [BATELE DISTRIBUTICH OFFICE
|4 331 LIZ HERNANDEZ DISTRIEUTICN OFFICE
|5 p33a [F.LTUL FANIREZ FUMA Whs (AHM)
| 6 p336 Meff Cummins O ACCESS v}
. 2

Cancel ] < Back ] [ext = | Finish ]

Step2-5. Import Excel Data to Access

Press “Finish” button

& Import Spreadsheet Wizard Ead

¥ou can store your data in a new table or in an existing table.

Where would you like to store your data?
= :
" In an Existing Table: | |

MNurder |[First Name |Last Name Access Lewvel

| 1498 Do [ood GRLND MASTER G
|2 p328 WICEY MARTINEZ DISTRIEUTION OFFICE

|3 p330 MELINDA [FATELE DISTRIEUTICON OFFICE

|4 331 LIZ HEEWANDEZ DISTRIEUTICN OFFICE

|5 p33a [FATL RANIREZ FUMA Wh= (LHN)

| 6 p336 Merff Cummins NO ACCESS 71
4

Cancel < Back ] [ext = | Finish ]
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Step2-6. Set Primary key

Press “Design” button

E= nyk : Database

Qpen I%Qﬁsign ?:Eﬂew | }( ! Eg n,__“'

Objects Create table in Design view

Create table by using wizard

Create table by entering data

TR

Step2-7. Set Primary key
Right click on the “Number” Row -> Primary Key -> Save & Exit file (The Field Name “Number” represents the

employee ID and not the card number.)

B nyk : Table

Field Mame | DataT pe [ Description
Autonumber

Text
Text
Text
Text
Mumber
[ 3«1 Insert Rows
i = Delete Rows
— N puild...
= Properties
Field Properties
General I Loakup I
Field Size Double
Farmat
Decimal Places Auta
Input Mask
Caption
Default Yalue A field name can be up to 64 charackers long, ir
Walidation Rule
Walidation Text
Required Mo
Indexed ‘es (Duplicates OK)
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Step2-8. Open ASDManager.exe

Double click ASDManager.exe at c:\Access ControNASManager

& ASManager

File Edit Wew Favorites Help
-\_J Llﬂ; )‘:] Search lt Folders -
Address |03 Ci\Access ControllASManager v| &
= (A Mame - Sige  Type Dake Modified |
File and Folder Tasks ' Americalls 1,011 KE EINFile 4/16/2009 5§32 AM
) Rename thi Fie AmericalDs 199KE DAT File 4}16/2009 §:32 AM
AS200Y200_20090507.550 103KE  AS0 File 5/7/2009 7:14 PM
Ly Move this File ASZ00Web_W¥200_090313 1,214 KB  EIN File 3132009 10:57 AM
(Y Copy this file AS400URIE_Y100_20090924 1,763 KE  EINFils 9}24 /2009 9:34 FM B
@ Publish this File to the =] AsConfig 10Z KB #ML Document 5/19/2009 7110 P
Web ASConfig.O 456 KE OFile 6252007 4:36 PM
(3] E-mail this file ] ascanfig.dl 603 KB  Application Extension  7/14/2009 &:32 FM
¥ Delate this fil L’Q AsDateTime, dll 33KE Application Extension  2/11/2009 3:53 PM
@ASDBAutnUpdate 316 KB  Application 10/29/2009 6:05 PM
ASDBField. StringTable 16KE STRINGTAELE File 3/18{2010 3:50 PM
Other Places ASDEField. StringTable. bak 16KE BAK File 3/15/2010 6:45 PM
53 Access conirel ; 480KE  Application 10/29/2009 6:06 PM
: ASDEToal,5tringTable B1KE STRINGTAELE Fils 9/2}2009 4:01 PM
(L3 My Documents fisialDs SSSKE  EIM File 6/3/2009 11:58 AM
[ Shared Documents AsialDs 106 KE DATFile 6/10/2009 9:41 AM
:.‘ Iy Compuker ﬂASLog 345 KE  Application 412009 5:24 PM
& My Network Places AsLog 44 KB  ¥ML Document 7142008 5:40 PM
Aslag.O 256 KE  0OFie 6/13/2007 4:12 FM
AsLog.1 Z56KE 1 File 711/2008 2:00 PM
Details ES @ASLDg.exe.maniFest 1 KE MANIFEST File 372006 5:33 PM
+ | = AsLog.stringTable 4KE STRINGTAELE File 12{2{2008 6:10 PM -

Step2-9. Set connection

Press “Setting from Source to ASManager Database” button

%1 Database Tools

Please Select Databaze Tools

Which tool do you uze for databaze?

AS5kanager Database Setting :

Setup, upgrade, deletion, backup and recovery.

Settings from Source to ASManager Databaze

Set the connection of Source Databaze, the mapping relations of the tables
between Source and AShanager databasze, the auto-update request, and the
manual update request,

Fie-login l L Exit J

GeoVision INC.
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Step2-10. Set Connection
Press “Set Connection” button
L Options

X

| Set Connection ;

Input/todify the infarmation for source databaze connection.

Set Mapping :
Set the mapping relations for cardholder.

| Set Mapping :

Set the mapping relations for cards.

Input /M odify the Auto-update time setting,

| Update Cardhalders D ata manually

|Update [nfarmatian. ..

|dpdate Card D ata manually

|Update |nfarmation...

Source Database: Microsoft, Jet, OLEDE, #.0

Step2-11. Set Connection
Select “Other Database” -> OK

Flease select the source database. =
hess
Source Databaze
() Active Directary
(%) Other D atabase

| OF. | [ Cancel

GeoVision INC. P R O F E S S I O N A L
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Step2-12. Set Connection

Select “Microsoft Jet 4.0 OLEDB Provider” -> Next

Provider | Cornection | Advanced | &I |

Select the data you want to connect bo;

OLE DB Provider(z]

Jet 4 0 0OLE DE Provider
Microgoft OLE DB Provider for Indesing Service
Microgoft OLE DB Provider for Intermet Publishing
Microzoft OLE DB Provider for DDBC Drivers
Microzoft OLE DB Provider for OLAP Services
Microzoft OLE DB Provider for Dracle
Microzoft OLE DB Provider for SQL Server
Microsoft OLE DB Simple Provider
MSDataShape
OLE DB Provider for Microsoft Directory Services

[ (]9 l[ Cancel J[ Help J

Step2-13. Set Connection

Press button

B2 Data Link Properties

Provider | Eonnectian |-.f?«dvanced [an |

Specify the following to connect to Access data;

1. Select ter a datab ;
elect or enter a databaze name —

ients and Settings\.ﬁ.dministrator'\Desktop'\db2_en.md‘) |
|

2. Enter information to log on to the database:

|Jzer hame: |Admin |

Blank password [ Allow saving password

Test Connection

[ QK l[ Cancel ][ Help J

GeoVision INC. P R O F
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Step2-14. Set Connection

Select mdb file (Customer’s database) -> open

Look jm: |@Desktop V| ] T BP [

L ﬁ:]My Diocurnents
@ lj My Computer
by Recent ‘HMV Metwork Places
Documents (L) pic

— [a tmp
F—_

K #2123

Desktop @ dbl

@ dbz_en

<

My Documents

My Carmputer

-

File name: |n_l.Jk hd | [_ Open J

bl Metwork Files of type: | ticrozoft Access D atabazes [“.mdb) - | [ Cancel ]

Step2-15. Set Connection
Press “OK” button

B0 Data Link Properties

Pravider | Connectian |.-’-'-.|:Ivan|:eu:| || Al

Specify the following to connect to Access data;

1. Select or enter a databaze name:

!E:'&Dn:n::uments and Settingz'\ AdrminiztratorsDesktophny |

2. Enter information to log on ta the database:

Idzer name: |.-“-‘-.|:|min |

Fazzword | |

Blank pazsword [ ] Allow zaving password

Test Connection

[ k. ][ Cancel ][ Help ]
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Step2-16. Set Mapping : Card Holder
“Set Mapping(Set the mapping

relations for cardholder)” button

Set Connection

Input/todify the information far source database connection.

Set Mapping :
Set the mapping relations for cardholder.

Set Mapping :
Set the mapping relations for cards.

Input/tdodify the Auto-update time setting.

Update Cardholders Data manually

Update Informatior...

Update Card Data manually

Update Infarmation...

Source Datahase: Microsoft, Jet, OLEDE 4.0

Step2-17. Set Mapping : Card Holder
Press “Add” button

& Mapping Setting

E Add a table from your database corresponding to the card holder table, and then set the mapping relations of their
fields.
S
Table Name Irrmation
Description
PFlease add a table that can be associated with the table "Cardholder.
Add Delete
Immediate iew 10 (0~100) [[] &uto Column Width
Narne First Mame  Last Name Send 5SM5  SMS 1D Gender | Bithdsy  EmplopeslD  Home Phone  Home Fax - Mobile Phone | Home ZipCad

5|

Clear Save Cancel

|~

GeoVision INC.
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Step2-18. Set Mapping : Card Holder
Select Table(want to import) -> OK

Add a Table

Fleaze add a table that can be azzociated with the table 'Cardholder’,

Table Mame :

Step2-19. Set Mapping : Card Holder
Press = button on “ID” Row.

& Mapping Setting [__||E||E|
L\? Add a table from your database corresponding to the card holder table. and then set the mapping relations of their
fields.
~=
Table Hame | [rvk] |
Tk,
(k] Mapping Relations
Figld Name Figld Type +  Mapping Fields iy
% Marne nivarChar £=> @
% First Mame nitarChar =
= Last tiame nivarChar «=> G
[ send sts Bioal «=> Bg
|__-é_| SM3 nitarhar == &
% 10 niarChar «=> & L}
% Gender Biool =
% Birthday DateTime c=> &g
% EmployeelD nivarChar == [
Horme Phone narChar «=> &
% Harne Fax niarChar == [
% Mobile Phane niarChar <=2 @
&= Home zipCade nivarChar «=> G
% Home Address nivarChar == @ .
[ add ” Delete ] = R b P i
Immediate Yiew : |'ID | [0~1001 [[] Auto Column ‘width
MHame First Mame ~ Last Mame Send SMS | SMS D Gender  Bithday EmployeelD  Home Phone HomeFax Mobile Phone Home ZipCod
5] 3|
Clear Save Cancel

GeoVision INC. P R O F E S S | O N A L
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Step2-20. Set Mapping : Card Holder
Select “Number” -> Add -> OK

Set the mapping fields

@  Destination Field 2100
‘g Select the source fields for mapping.

X

Fieldz Mapping Fieldz

Figld M arne Figld Type Field Mame Figld Type
E {10 Integer
E| [Mumber] Double

E| [Firzt M ame] WarwChar

(1] 4
E [Last Mame] Warw'Char

E| [hooess Level]  Warw/Char Cancel
E [Statusz] Warw'Char
= [Card Mo Dauble
P
DN

Set Foreign Fey

Step2-21. Set Mapping : Card Holder
Please follow Step2-19~Step2-20 to mapping database for other fields such as Name, gender, etc -> Save

& Mapping Setting

'E‘ Add a table from your database corresponding to the card holder table. and then set the mapping relations of their
fields.
~=
Table Hame | [rvk] |
Tk,
(k] Mapping Relations
Figld Name Figld Type +  Mapping Fields i
% Marne nivarChar £=> @
% First Mame nitarChar =
= Last tiame nivarChar «=> G
[ send sts Bioal «=> Bg
|__-é_| SM3 nitarhar == &
% 10 niarChar «=> & L}
% Gender Biool =
% Birthday DateTime c=> &g
% EmployeelD nivarChar == [
|__-é_| Home Phone niarChar == @
% Harne Fax niarChar == [
% Mobile Phane niarChar <=2 @
&= Home zipCade nivarChar «=> G
% Home Address nivarChar == @ .
[ add ” Delete ] = R b e ER i
Immediate Yiew : |'ID | [0~1001 [[] Auto Column ‘width
MHame First Mame ~ Last Mame Send SMS | SMS D Gender  Bithday EmployeelD  Home Phone HomeFax Mobile Phone Home ZipCod
5] 3|
Clear Save Cancel |
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Step2-22. Set Mapping : Card
“Set Mapping (

| Set Corinection :

Input/todify the information far source database connection.

. Set Mapping :
Set the mapping relations for cardholder.

| et Mapping :
Set the mapping relations for cards.

| Input/tdodify the Auto-update time setting.

| Update Cardhalders Data manually

Update Informatior...

. Update Card Data manually

Update Infarmation...

Source Datahase: Microsoft, Jet, OLEDE 4.0

Step2-23. Set Mapping : Card
Select a source table

& Set the mapping relations for cards.

Using field mapping to establish relation between fields from the Card and S ource.

Set the mapping relations for cards)”

button

Select a source table :

-

Fied Name I
E‘ Cardholder Integer L
E| Card Mumber n¥arChar Lo
E%] Code Type Integer LS
E‘ Achvation Date [rateTime Sy
Deactivation D ate DrateTime L5
E| Deactivate [ves/Mo) Bool (e
E%J Fin Code rivfarChar Lo
Access Groups nivarChar e

Field Type

Immediate Yiew

[0~ 100)

|-

Cardholder . Card Mumber | Code Type . Activation Date . Deactivation Date | Deactivate [Yes/Mo] | Pin Code

GeoVision INC.
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Step2-24. Set Mapping : Card

Click “Field Name” at “Cardholder” column

& Set the mapping relations for cards.

|Jzing field mapping to establizh relation between fields from the Card and Source.

Select a zource table ;

[rk]

Field Marme
E Cardholder
E' Card Mumber
E Code Type
E' Activation Date
E Deactivation Date
E' Deactivate [Tez/Mo]
(= Fin Code
Access Groups

Field Type

Inteqer
nifarChar
Inteqer
DateTime
DateT ime
Eool

v arChar
nifarChar

Eee Field Mame

T A A A e
et Ve B

Figld Type

Immediate Yiew

|E__| [0~ 100

Cardholder  Card Mumber

|~

Code Type

Activation D ate

Deactivation Date

Deactivate [vez/Mo]

Fin Code

[ Clear

||

Step2-25. Set Mapping : Card

Select “Number” on Source Field -> Select “ID” on Mapping

Set the mapping fields

Set the mapping figlds between the Cardhaolder and the Card.

M apping Relationz
Source Field =r Mapping field of Cardholder
Pumbe v R |
[ ok ] [ Cancel ]
GeoVision INC. P R O F E S S
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Step2-26. Set Mapping : Card
Please follow Step2-24~Step2-25 to finish database mapping for card number, code type, Access Group -> OK

t2; Set the mapping relations for. cards.

I1zing field mapping to establizh relation between fields from the Card and Source.

Select a sounce table ;

k] v
Field Mame Field Type <> | Field Hame Field Tupe
E Cardholder |nteger LS [Mumber] == 1D Double =x marChar
E| Card Mumber i arChar L [Card Ma] [rouble
E| Code Type |nteger <=x Wiegandz26
E Activation Date DateTime L
E Deactivation [ ate DateTime {3
E Deactivate [YezdMo] B ool L
E Fin Code riarChar L
E Aocess Groups i ar-har L

Immediate View |10 (0~ 100]

Cardholder Card Mumber . Code Type | Activation Date | Deactivation Date | Deactivate [Yes/Mao]  Pin Code

< [ | 3

Clear ] [_ ] 8 ] [ Cancel
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Step2-27. Update Cardholder & Card Data
Press “Update Cardholders Data manually” button -> Press “U

) ptions

Set Mapping :

| Set tapping :

|nput /W adify the Auto-update time zetting.

' |Ipdate Cardholders Data manually

Ilpdate Card Diata manually

Set Connection

|nput/d odify the information for source database connection,

Set the mapping relations for cardholder.

Set the mapping relations for cardz.

|Ipdate [nfarmation...

Ilpdate Information...

Source Database; Microsaft, Jet, OLEDE . 4.0

GeoVision INC.
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pdate Card Data manually” button -> Finished
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